All systems operational

Completed
Quoox website maintenance

Status
Resolved after about 2 hours
Started
July 03, 2022 at 7:30 AM
Completed
July 03, 2022 at 9:27 AM
Affects
Quoox Website
  • Completed
    July 03, 2022 at 9:27 AM

    Maintenance has completed successfully.

  • In progress
    July 03, 2022 at 7:30 AM

    Maintenance is now in progress

  • Planned
    July 03, 2022 at 7:30 AM

    The Quoox website will be down for scheduled maintenance.

    The Quoox GMS system; mobile app; FitnessHub; and support site will all be unaffected.